Project

General

Profile

Feature #371

secureLoad

Added by iri about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
OS3D_Ergonomy
Target version:
-
Start date:
11/12/2011
Due date:
% Done:

0%

Estimated time:

Description

If an error occurs (_testpack doesn't return nil), a dialog box is displayed but the message is wrong (This version of OpenSpace3D Editor is not compatible with your Scol Voy@ger version.\nPlease perform an update.")

The log message isn't explicit. It could be :
_fooS strcatn ">>>>> Compilation error : " :: ret :: ". Package : " :: pack :: nil;

(or use sprintf function if syspack is included)

History

#1 Updated by arkeon about 8 years ago

  • Status changed from New to Closed
  • Assignee set to arkeon

Already done on OS3D editor (trunk version), the player keep the non updated version (for final users)

#2 Updated by iri about 8 years ago

I don't understand your response.
I've the trunk version but the player (and the editor ?) keep or not the updated version doesn't change my question.

See os3deditor/os3dload.pkg, secureLoad and loadOS3D functions

#3 Updated by arkeon about 8 years ago

Actually if a compilation error append in the OS3Dloader, a popup with a text container is displayed with the scol error message.

but for the os3dPlayer only the "need update" message is displayed.

Also available in: Atom PDF